summaryrefslogtreecommitdiffstats
path: root/winsup/cygwin/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'winsup/cygwin/configure.in')
-rw-r--r--winsup/cygwin/configure.in38
1 files changed, 9 insertions, 29 deletions
diff --git a/winsup/cygwin/configure.in b/winsup/cygwin/configure.in
index 6a762e071..9ad229c38 100644
--- a/winsup/cygwin/configure.in
+++ b/winsup/cygwin/configure.in
@@ -1,5 +1,5 @@
dnl Autoconf configure script for Cygwin.
-dnl Copyright 1996, 1997, 1998, 2000, 2001 Red Hat, Inc.
+dnl Copyright 1996, 1997, 1998, 2000, 2001, 2002, 2003 Red Hat, Inc.
dnl
dnl This file is part of Cygwin.
dnl
@@ -118,27 +118,6 @@ if test $use_builtin_memset = "yes"; then
fi
AC_LANG_RESTORE
-dnl set default mt safeness and then process the options.
-mt_safe_val=1
-MT_SAFE=yes
-
-AC_ARG_ENABLE(threadsafe,
-[ --enable-threadsafe=[runtime] Build a cygwin DLL which is thread safe],
-[case "${enableval}" in
-yes)
- dnl default.
- ;;
-runtime)
- mt_safe_val=2
- MT_SAFE=yes
- ;;
-no)
- mt_safe_val=0
- MT_SAFE=no
- ;;
-esac
-])
-
AC_ARG_ENABLE(extra-threadsafe-checking,
[ --enable-extra-threadsafe-checking Build a cygwin DLL which is thread safe with extra consistency checking],
[case "${enableval}" in
@@ -153,13 +132,6 @@ no)
esac
])
-if test "$MT_SAFE" = "yes"; then
- AC_DEFINE_UNQUOTED(_MT_SAFE,$mt_safe_val)
-fi
-
-dnl Makefile uses MT_SAFE, so we subst as well as defining it.
-AC_SUBST(MT_SAFE)
-
AC_ARG_ENABLE(debugging,
[ --enable-debugging Build a cygwin DLL which has more consistency checking for debugging],
[case "${enableval}" in
@@ -168,6 +140,14 @@ no) ;;
esac
])
+AC_ARG_ENABLE(cygserver,
+[ --enable-server Build a cygwin DLL which can communicate with cygserver],
+[case "${enableval}" in
+yes) AC_DEFINE(USE_CYGSERVE) ;;
+no) ;;
+esac
+])
+
MALLOC_OFILES=
AC_ARG_ENABLE(malloc-debugging,
[ --enable-malloc-debugging Build a cygwin DLL with heap sanity checking (this is very slow, use only if you have heap corruption problems)],