summaryrefslogtreecommitdiffstats
path: root/winsup/cygwin/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'winsup/cygwin/configure.in')
-rw-r--r--winsup/cygwin/configure.in13
1 files changed, 5 insertions, 8 deletions
diff --git a/winsup/cygwin/configure.in b/winsup/cygwin/configure.in
index d47b4084f..c560301b1 100644
--- a/winsup/cygwin/configure.in
+++ b/winsup/cygwin/configure.in
@@ -135,16 +135,17 @@ no) ;;
esac
])
+LIBSERVER='$(bupdir)/cygserver/libcygserver.a'
AC_ARG_ENABLE(server,
[ --enable-server Build a cygwin DLL which can communicate with cygserver],
[case "${enableval}" in
-yes)
- AC_DEFINE(USE_SERVER)
- LIBSERVER='$(bupdir)/cygserver/libcygserver.a' ;;
-no) LIBSERVER=;;
+yes) ;;
+no) LIBSERVER=;;
esac
])
+test -n "$LIBSERVER" && AC_DEFINE(USE_SERVER)
+
MALLOC_OFILES=malloc.o
AC_ARG_ENABLE(malloc-debugging,
[ --enable-malloc-debugging Build a cygwin DLL with heap sanity checking (this is very slow, use only if you have heap corruption problems)],
@@ -186,10 +187,6 @@ case "$target_cpu" in
DEF_DLL_ENTRY="dll_entry@12"
ALLOCA="_alloca"
CONFIG_DIR="i386" ;;
- powerpc*) DLL_ENTRY="dll_entry"
- DEF_DLL_ENTRY="dll_entry"
- ALLOCA=" __allocate_stack"
- CONFIG_DIR="ppc" ;;
*) AC_MSG_ERROR(Invalid target processor \"$target_cpu\") ;;
esac