summaryrefslogtreecommitdiffstats
path: root/winsup/cygwin/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'winsup/cygwin/configure.in')
-rw-r--r--winsup/cygwin/configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/winsup/cygwin/configure.in b/winsup/cygwin/configure.in
index c560301b1..04c961c19 100644
--- a/winsup/cygwin/configure.in
+++ b/winsup/cygwin/configure.in
@@ -75,13 +75,17 @@ case "$with_cross_host" in
""|*cygwin*)
all_host="all_host"
install_host="install_host"
+ LIBSERVER='$(bupdir)/cygserver/libcygserver.a'
;;
*)
all_host=
install_host=
+ LIBSERVER=
;;
esac
+test -n "$LIBSERVER" && AC_DEFINE(USE_SERVER)
+
AC_SUBST(all_host)
AC_SUBST(install_host)
@@ -135,7 +139,6 @@ no) ;;
esac
])
-LIBSERVER='$(bupdir)/cygserver/libcygserver.a'
AC_ARG_ENABLE(server,
[ --enable-server Build a cygwin DLL which can communicate with cygserver],
[case "${enableval}" in
@@ -144,8 +147,6 @@ no) LIBSERVER=;;
esac
])
-test -n "$LIBSERVER" && AC_DEFINE(USE_SERVER)
-
MALLOC_OFILES=malloc.o
AC_ARG_ENABLE(malloc-debugging,
[ --enable-malloc-debugging Build a cygwin DLL with heap sanity checking (this is very slow, use only if you have heap corruption problems)],