summaryrefslogtreecommitdiffstats
path: root/newlib/libc/machine/spu/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/machine/spu/configure.in')
-rw-r--r--newlib/libc/machine/spu/configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/newlib/libc/machine/spu/configure.in b/newlib/libc/machine/spu/configure.in
index 7c5011ab6..a287ff59b 100644
--- a/newlib/libc/machine/spu/configure.in
+++ b/newlib/libc/machine/spu/configure.in
@@ -10,5 +10,21 @@ AC_CONFIG_AUX_DIR(../../../..)
NEWLIB_CONFIGURE(../../..)
+AC_MSG_CHECKING([whether the compiler supports __ea])
+dnl We do not use AC_COMPILE_IFELSE to support building newlib with
+dnl a cross-compiler that is not (yet) able to link executables
+cat > conftest.c <<EOF
+#if defined (__EA32__) || defined (__EA64__)
+ yes;
+#endif
+EOF
+if AC_TRY_COMMAND(${CC-cc} -E conftest.c) | egrep yes >/dev/null 2>&1; then
+ spu_compiler_has_ea=yes
+else
+ spu_compiler_has_ea=no
+fi
+AM_CONDITIONAL(HAVE_SPU_EA, test x${spu_compiler_has_ea} != xno)
+AC_MSG_RESULT($spu_compiler_has_ea)
+
AC_CONFIG_FILES([Makefile])
AC_OUTPUT