summaryrefslogtreecommitdiffstats
path: root/newlib/libc/machine/sh/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/machine/sh/configure.in')
-rw-r--r--newlib/libc/machine/sh/configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/newlib/libc/machine/sh/configure.in b/newlib/libc/machine/sh/configure.in
index ffd27974d..7fb5afd0e 100644
--- a/newlib/libc/machine/sh/configure.in
+++ b/newlib/libc/machine/sh/configure.in
@@ -9,4 +9,11 @@ AC_CONFIG_AUX_DIR(../../../..)
NEWLIB_CONFIGURE(../../..)
+AC_EGREP_CPP([sh5], [
+#if __SH5__
+ sh5
+#endif
+], [have_sh64=yes], [have_sh64=no])
+AM_CONDITIONAL(SH64, [test $have_sh64 = yes])
+
AC_OUTPUT(Makefile)