summaryrefslogtreecommitdiffstats
path: root/newlib/libc/machine/powerpc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/machine/powerpc/Makefile.am')
-rw-r--r--newlib/libc/machine/powerpc/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/newlib/libc/machine/powerpc/Makefile.am b/newlib/libc/machine/powerpc/Makefile.am
index 1c65b9ffe..4ddc19ac8 100644
--- a/newlib/libc/machine/powerpc/Makefile.am
+++ b/newlib/libc/machine/powerpc/Makefile.am
@@ -7,6 +7,19 @@ INCLUDES = $(NEWLIB_CFLAGS) $(CROSS_CFLAGS) $(TARGET_CFLAGS)
noinst_LIBRARIES = lib.a
lib_a_SOURCES = setjmp.S
+lib_a_LIBADD = @extra_objs@
+EXTRA_lib_a_SOURCES = @extra_sources@
+lib_a_DEPENDENCIES = @extra_objs@
-ACLOCAL_AMFLAGS = -I ../../..
+ACLOCAL_AMFLAGS = -I ../../..
+AM_CFLAGS = -I $(srcdir)/../../stdio
CONFIG_STATUS_DEPENDENCIES = $(newlib_basedir)/configure.host
+
+VEC_MALLOC_COMPILE = $(COMPILE) -DINTERNAL_NEWLIB
+
+vec_reallocr.o: vec_mallocr.c
+ $(VEC_MALLOC_COMPILE) -DDEFINE_VECREALLOC -c $(srcdir)/vec_mallocr.c -o $@
+
+vec_callocr.o: vec_mallocr.c
+ $(VEC_MALLOC_COMPILE) -DDEFINE_VECCALLOC -c $(srcdir)/vec_mallocr.c -o $@
+