summaryrefslogtreecommitdiffstats
path: root/newlib/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/configure.in')
-rw-r--r--newlib/configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/newlib/configure.in b/newlib/configure.in
index db1c6b1ba..8e742f786 100644
--- a/newlib/configure.in
+++ b/newlib/configure.in
@@ -181,6 +181,19 @@ AC_ARG_ENABLE(newlib-unbuf-stream-opt,
esac
fi], [newlib_unbuf_stream_opt=yes])dnl
+dnl Support --enable-lite-exit
+dnl Lite exit is a size-reduced implementation of exit that doesn't invoke
+dnl clean-up functions such as _fini or global destructors.
+AC_ARG_ENABLE(lite-exit,
+[ --enable-lite-exit enable light weight exit],
+[if test "${lite_exit+set}" != set; then
+ case "${enableval}" in
+ yes) lite_exit=yes ;;
+ no) lite_exit=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for lite-exit option) ;;
+ esac
+ fi], [lite_exit=no])dnl
+
NEWLIB_CONFIGURE(.)
dnl We have to enable libtool after NEWLIB_CONFIGURE because if we try and
@@ -390,6 +403,10 @@ if test "${newlib_unbuf_stream_opt}" = "yes"; then
AC_DEFINE_UNQUOTED(_UNBUF_STREAM_OPT)
fi
+if test "${lite_exit}" = "yes"; then
+AC_DEFINE_UNQUOTED(_LITE_EXIT)
+fi
+
dnl
dnl Parse --enable-newlib-iconv-encodings option argument
dnl