summaryrefslogtreecommitdiffstats
path: root/newlib/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/configure.in')
-rw-r--r--newlib/configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/newlib/configure.in b/newlib/configure.in
index 5646d64d0..db1c6b1ba 100644
--- a/newlib/configure.in
+++ b/newlib/configure.in
@@ -170,6 +170,17 @@ AC_ARG_ENABLE(newlib-nano-malloc,
esac
fi], [newlib_nano_malloc=no])dnl
+dnl Support --disable-newlib-unbuf-stream-opt
+AC_ARG_ENABLE(newlib-unbuf-stream-opt,
+[ --disable-newlib-unbuf-stream-opt disable unbuffered stream optimization in streamio],
+[if test "${newlib_unbuf_stream_opt+set}" != set; then
+ case "${enableval}" in
+ yes) newlib_unbuf_stream_opt=yes ;;
+ no) newlib_unbuf_stream_opt=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for newlib-unbuf-stream-opt option) ;;
+ esac
+ fi], [newlib_unbuf_stream_opt=yes])dnl
+
NEWLIB_CONFIGURE(.)
dnl We have to enable libtool after NEWLIB_CONFIGURE because if we try and
@@ -375,6 +386,10 @@ if test "${newlib_nano_malloc}" = "yes"; then
AC_DEFINE_UNQUOTED(_NANO_MALLOC)
fi
+if test "${newlib_unbuf_stream_opt}" = "yes"; then
+AC_DEFINE_UNQUOTED(_UNBUF_STREAM_OPT)
+fi
+
dnl
dnl Parse --enable-newlib-iconv-encodings option argument
dnl