summaryrefslogtreecommitdiffstats
path: root/winsup/cygwin/configure.in
diff options
context:
space:
mode:
authorChristopher Faylor <me@cgf.cx>2006-05-24 03:39:29 +0000
committerChristopher Faylor <me@cgf.cx>2006-05-24 03:39:29 +0000
commit12a7d844b91ae1fc56014a4af4ca91ab8cfca387 (patch)
treeff8fda3677d2dfd8f031d33ef4e6c6e592538c17 /winsup/cygwin/configure.in
parent9905786a044d421fb937bc52855defc2b45893f8 (diff)
downloadcygnal-12a7d844b91ae1fc56014a4af4ca91ab8cfca387.tar.gz
cygnal-12a7d844b91ae1fc56014a4af4ca91ab8cfca387.tar.bz2
cygnal-12a7d844b91ae1fc56014a4af4ca91ab8cfca387.zip
* select.cc (start_thread_socket): Delay setting thread local exitsock until we
know it's correct. Return correct value on error.
Diffstat (limited to 'winsup/cygwin/configure.in')
-rw-r--r--winsup/cygwin/configure.in55
1 files changed, 2 insertions, 53 deletions
diff --git a/winsup/cygwin/configure.in b/winsup/cygwin/configure.in
index 2b0d867dc..db6c51ff2 100644
--- a/winsup/cygwin/configure.in
+++ b/winsup/cygwin/configure.in
@@ -9,63 +9,12 @@ dnl details.
dnl
dnl Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.12)dnl
+AC_PREREQ(2.59)dnl
AC_INIT(init.cc)
AC_CONFIG_HEADER(config.h)
-
-INSTALL="/bin/sh "`cd $srcdir/../..; echo $(pwd)/install-sh -c`
+AC_CONFIG_AUX_DIR(../..)
AC_PROG_INSTALL
-
-dnl FIXME: We temporarily define our own version of AC_PROG_CC. This is
-dnl copied from autoconf 2.12, but does not call AC_PROG_CC_WORKS. We
-dnl are probably using a cross compiler, which will not be able to fully
-dnl link an executable. This should really be fixed in autoconf
-dnl itself.
-
-AC_DEFUN(LIB_AC_PROG_CC,
-[AC_BEFORE([$0], [AC_PROG_CPP])dnl
-AC_CHECK_TOOL(CC, gcc, gcc)
-if test -z "$CC"; then
- AC_CHECK_PROG(CC, cc, cc, , , /usr/ucb/cc)
- test -z "$CC" && AC_MSG_ERROR([no acceptable cc found in \$PATH])
-fi
-
-AC_PROG_CC_GNU
-
-if test $ac_cv_prog_gcc = yes; then
- GCC=yes
-dnl Check whether -g works, even if CFLAGS is set, in case the package
-dnl plays around with CFLAGS (such as to build both debugging and
-dnl normal versions of a library), tasteless as that idea is.
- ac_test_CFLAGS="${CFLAGS+set}"
- ac_save_CFLAGS="$CFLAGS"
- CFLAGS=
- AC_PROG_CC_G
- if test "$ac_test_CFLAGS" = set; then
- CFLAGS="$ac_save_CFLAGS"
- elif test $ac_cv_prog_cc_g = yes; then
- CFLAGS="-gstabs+ -O2"
- else
- CFLAGS="-O2"
- fi
-else
- GCC=
- test "${CFLAGS+set}" = set || CFLAGS="-g"
-fi
-])
-
-AC_DEFUN(LIB_AC_PROG_CXX,
-[AC_BEFORE([$0], [AC_PROG_CPP])dnl
-AC_CHECK_TOOL(CXX, g++, g++)
-if test -z "$CXX"; then
- AC_CHECK_PROG(CXX, c++, c++, , , )
- test -z "$CC" && AC_MSG_ERROR([no acceptable cc found in \$PATH])
-fi
-
-CXXFLAGS='$(CFLAGS)'
-])
-
AC_CANONICAL_SYSTEM
LIB_AC_PROG_CC