summaryrefslogtreecommitdiffstats
path: root/newlib/libm/mathfp/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2015-11-02 18:00:28 -0500
committerJeff Johnston <jjohnstn@redhat.com>2015-11-02 18:02:39 -0500
commit06312793945e184036b9491767b9eacac9be3890 (patch)
treeb8e4fbafe646bf9b186d1b93ff56d0f7c7794658 /newlib/libm/mathfp/Makefile.am
parent53617ce4e634bd6f67e6e08939518dba77dee3f1 (diff)
downloadcygnal-06312793945e184036b9491767b9eacac9be3890.tar.gz
cygnal-06312793945e184036b9491767b9eacac9be3890.tar.bz2
cygnal-06312793945e184036b9491767b9eacac9be3890.zip
Move duplicated documentation rules to Makefile.shared
- Also, harmonize libm to use CHEWOUT_FILES like libc, rather than chobj. Update documentation appropriately. * HOWTO: Update. * Makefile.shared: Move documentation rules to here... * libc/argz/Makefile.am: ... from here ... * libc/ctype/Makefile.am: ... and here. * libc/errno/Makefile.am: Ditto. * libc/iconv/Makefile.am: Ditto. * libc/iconv/ccs/Makefile.am : Ditto. * libc/iconv/ces/Makefile.am: Ditto. * libc/iconv/lib/Makefile.am: Ditto. * libc/locale/Makefile.am: Ditto. * libc/misc/Makefile.am: Ditto. * libc/posix/Makefile.am: Ditto. * libc/reent/Makefile.am: Ditto. * libc/search/Makefile.am: Ditto. * libc/stdio/Makefile.am: Ditto. * libc/stdio64/Makefile.am: Ditto. * libc/stdlib/Makefile.am : Ditto. * libc/string/Makefile.am: Ditto. * libc/syscalls/Makefile.am: Ditto. * libc/time/Makefile.am : Ditto. * libc/unix/Makefile.am: Ditto. * libc/xdr/Makefile.am: Ditto. * libm/common/Makefile.am: Ditto. * libm/complex/Makefile.am: Ditto. * libm/math/Makefile.am: Ditto. * libm/mathfp/Makefile.am: Ditto.
Diffstat (limited to 'newlib/libm/mathfp/Makefile.am')
-rw-r--r--newlib/libm/mathfp/Makefile.am17
1 files changed, 2 insertions, 15 deletions
diff --git a/newlib/libm/mathfp/Makefile.am b/newlib/libm/mathfp/Makefile.am
index 0caab07a4..db83ea082 100644
--- a/newlib/libm/mathfp/Makefile.am
+++ b/newlib/libm/mathfp/Makefile.am
@@ -58,7 +58,7 @@ endif # USE_LIBTOOL
include $(srcdir)/../../Makefile.shared
-chobj = e_acosh.def \
+CHEWOUT_FILES = e_acosh.def \
e_atanh.def \
e_hypot.def \
e_remainder.def \
@@ -87,20 +87,7 @@ chobj = e_acosh.def \
s_tanh.def \
w_jn.def
-SUFFIXES = .def
-
-CHEW = ../../doc/makedoc -f $(srcdir)/../../doc/doc.str
-
-.c.def:
- $(CHEW) < $< > $*.def 2> $*.ref
- touch stmp-def
-
-TARGETDOC = ../tmp.texi
-
-doc: $(chobj)
- cat $(srcdir)/mathfp.tex >> $(TARGETDOC)
-
-CLEANFILES = $(chobj) *.ref
+CHAPTERS = mathfp.tex
# A partial dependency list.