summaryrefslogtreecommitdiffstats
path: root/newlib/libm/machine/riscv/Makefile.am
diff options
context:
space:
mode:
authorKito Cheng <kito@andestech.com>2017-07-27 16:45:12 +0800
committerJeff Johnston <jjohnstn@redhat.com>2017-08-17 12:54:56 -0400
commit7040b2de0883e8346af9c976cd711cf75307e854 (patch)
treea974232927342683efd84c7ae496dbc7d1362f95 /newlib/libm/machine/riscv/Makefile.am
parent979d467ff6e39ee5c52cf1aac7a6c9c63058141c (diff)
downloadcygnal-7040b2de0883e8346af9c976cd711cf75307e854.tar.gz
cygnal-7040b2de0883e8346af9c976cd711cf75307e854.tar.bz2
cygnal-7040b2de0883e8346af9c976cd711cf75307e854.zip
Add RISC-V port for libm
Contributor list: - Michael Neilly <mneilly@yahoo.com> - Kito Cheng <kito.cheng@gmail.com>
Diffstat (limited to 'newlib/libm/machine/riscv/Makefile.am')
-rw-r--r--newlib/libm/machine/riscv/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/newlib/libm/machine/riscv/Makefile.am b/newlib/libm/machine/riscv/Makefile.am
new file mode 100644
index 000000000..1b9f48a25
--- /dev/null
+++ b/newlib/libm/machine/riscv/Makefile.am
@@ -0,0 +1,20 @@
+## Process this file with automake to generate Makefile.in
+
+INCLUDES = -I $(newlib_basedir)/../newlib/libm/common $(NEWLIB_CFLAGS) \
+ $(CROSS_CFLAGS) $(TARGET_CFLAGS)
+
+LIB_SOURCES = \
+ feclearexcept.c fe_dfl_env.c fegetenv.c fegetexceptflag.c \
+ fegetround.c feholdexcept.c feraiseexcept.c fesetenv.c \
+ fesetexceptflag.c fesetround.c fetestexcept.c feupdateenv.c
+
+noinst_LIBRARIES = lib.a
+lib_a_SOURCES = $(LIB_SOURCES)
+lib_a_CFLAGS = $(AM_CFLAGS)
+lib_a_CCASFLAGS = $(AM_CCASFLAGS)
+noinst_DATA =
+
+include $(srcdir)/../../../Makefile.shared
+
+ACLOCAL_AMFLAGS = -I ../../.. -I ../../../..
+CONFIG_STATUS_DEPENDENCIES = $(newlib_basedir)/configure.host