summaryrefslogtreecommitdiffstats
path: root/newlib/libc/unix/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2005-04-08 20:48:40 +0000
committerJeff Johnston <jjohnstn@redhat.com>2005-04-08 20:48:40 +0000
commit6e75bff67d6a4b6b96523be31bf581c2feae43c9 (patch)
treedf95f5011ba2266371f8447aa54bfcd68d996522 /newlib/libc/unix/Makefile.am
parentc400419414d491bb1e907da89be634c5f4ce3749 (diff)
downloadcygnal-6e75bff67d6a4b6b96523be31bf581c2feae43c9.tar.gz
cygnal-6e75bff67d6a4b6b96523be31bf581c2feae43c9.tar.bz2
cygnal-6e75bff67d6a4b6b96523be31bf581c2feae43c9.zip
2005-04-08 Jeff Johnston <jjohnstn@redhat.com>
* libc/include/libgen.h: New file. 2005-04-08 Shaun Jackman <sjackman@gmail.com> * libc/unix/Makefile.am: Add support for basename and dirname. * libc/unix/Makefile.in: Regenerated. * libc/unix/basename.c: New file. * libc/unix/dirname.c: New file.
Diffstat (limited to 'newlib/libc/unix/Makefile.am')
-rw-r--r--newlib/libc/unix/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/newlib/libc/unix/Makefile.am b/newlib/libc/unix/Makefile.am
index a5d57cf87..6ecee1397 100644
--- a/newlib/libc/unix/Makefile.am
+++ b/newlib/libc/unix/Makefile.am
@@ -15,6 +15,8 @@ ELIX_2_OBJS = \
ttyname.$(oext)
ELIX_4_OBJS = \
+ basename.$(oext) \
+ dirname.$(oext) \
getlogin.$(oext) \
getpass.$(oext) \
getpwent.$(oext) \