summaryrefslogtreecommitdiffstats
path: root/newlib/libc/sys/linux/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2003-06-20 23:57:48 +0000
committerJeff Johnston <jjohnstn@redhat.com>2003-06-20 23:57:48 +0000
commit8266e478d66f551e471e94a25de35db9f8f5e4c0 (patch)
tree93889b2a0b69900d38549bb2e3bcda366aea14a0 /newlib/libc/sys/linux/Makefile.am
parenta49a74108c573699f1b61e2c437ddce1e6db607d (diff)
downloadcygnal-8266e478d66f551e471e94a25de35db9f8f5e4c0.tar.gz
cygnal-8266e478d66f551e471e94a25de35db9f8f5e4c0.tar.bz2
cygnal-8266e478d66f551e471e94a25de35db9f8f5e4c0.zip
2003-06-20 Jeff Johnston <jjohnstn@redhat.com>
* libc/include/sys/reent.h (_REENT_INIT_PTR): Fix macros to handle latest on_exit change. * libc/sys/linux/Makefile.am: Remove special compilation for malloc.c and mcheck.c. * libc/sys/linux/Makefile.in: Regenerated. * libc/sys/linux/mntent.c: Add definition of _LIBC flag after including <features.h>. * libc/sys/linux/mcheck.c: Ditto. * libc/sys/linux/malloc.c: Ditto plus define _GNU_SOURCE for <features.h>. * libc/sys/linux/intl/Makefile.am: Remove -D_LIBC and add -DNOT_IN_libc to C flags. * libc/sys/linux/intl/Makefile.in: Regenerated. * libc/sys/linux/intl/config.h: Add definition of _LIBC. * libc/sys/linux/linuxthreads/semaphore.h: Include <bits/pthreadtypes.h>. * libc/sys/linux/sys/dirent.h: Define _LIBC and NOT_IN_libc after including <features.h>. * libc/sys/linux/sys/lock.h: Ditto.
Diffstat (limited to 'newlib/libc/sys/linux/Makefile.am')
-rw-r--r--newlib/libc/sys/linux/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/newlib/libc/sys/linux/Makefile.am b/newlib/libc/sys/linux/Makefile.am
index be9790308..935f60d03 100644
--- a/newlib/libc/sys/linux/Makefile.am
+++ b/newlib/libc/sys/linux/Makefile.am
@@ -224,12 +224,6 @@ crt0.o: machine/crt0.o
machine/crt0.o: ; @true
-malloc.$(oext): $(srcdir)/malloc.c
- $(LIBC_COMPILE) -D_LIBC=1 -c $< -o $@
-
-mcheck.$(oext): $(srcdir)/mcheck.c
- $(LIBC_COMPILE) -D_LIBC=1 -c $< -o $@
-
sig.$(oext): siglist.inc
siglist.inc: