summaryrefslogtreecommitdiffstats
path: root/newlib/libc/sys/linux/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2002-04-04 22:41:11 +0000
committerJeff Johnston <jjohnstn@redhat.com>2002-04-04 22:41:11 +0000
commit6e6cd5bde6164914615f5e82a1b49ed5b2c25eb9 (patch)
tree04c16a09dc72fc5f5379865a9916b2ec8c8f4616 /newlib/libc/sys/linux/Makefile.am
parent244a8fae426a68ad51cd610cebd1361a834d676a (diff)
downloadcygnal-6e6cd5bde6164914615f5e82a1b49ed5b2c25eb9.tar.gz
cygnal-6e6cd5bde6164914615f5e82a1b49ed5b2c25eb9.tar.bz2
cygnal-6e6cd5bde6164914615f5e82a1b49ed5b2c25eb9.zip
2002-04-04 Jeff Johnston <jjohnstn@redhat.com>
* Makefile.am: Add support for installing crt1.o if one exists. * configure.host: Specify crt1.o for linux. * configure.in: Expose CRT1 and CRT1_DIR for Makefile.am to use. * Makefile.in: Regenerated. * configure: Ditto. * libc/include/sys/unistd.h (_SC_STREAM_MAX, _SC_PRIORITY_SCHEDULING): Added for non-Cygwin, non-RTEMS configurations. * libc/sys/linux/Makefile.am: Add support for crt1 and sysconf. * libc/sys/linux/Makefile.in: Regenerated. * libc/sys/linux/crt1.c: New empty file to override one defaulted by gcc. This fixes problem with reconfiguring linux newlib build. * libc/sys/linux/sysconf.c: New file.
Diffstat (limited to 'newlib/libc/sys/linux/Makefile.am')
-rw-r--r--newlib/libc/sys/linux/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/newlib/libc/sys/linux/Makefile.am b/newlib/libc/sys/linux/Makefile.am
index 7c936a9a4..a3a0bbe89 100644
--- a/newlib/libc/sys/linux/Makefile.am
+++ b/newlib/libc/sys/linux/Makefile.am
@@ -9,7 +9,7 @@ SUBLIBS = $(LINUX_MACH_LIB)
LIB_SOURCES = \
brk.c getoptlong.c ids.c inode.c io.c linux.c process.c realpath.c \
- select.c signal.c socket.c sleep.c stack.c systat.c termios.c time.c \
+ select.c signal.c socket.c sleep.c stack.c sysconf.c systat.c termios.c time.c \
usleep.c wait.c
# This will handle both /usr/src/linux-2.4/include/asm/signal.h (in Red Hat Linux 7.1)
@@ -37,7 +37,7 @@ lib.a: $(LINUX_MACH_LIB) $(lib_a_OBJECTS)
cd tmp; \
for i in $(SUBLIBS); do \
$(AR) x ../$$i; \
- done; \
+ done; \
$(AR) $(AR_FLAGS) ../$@ *.o
$(RANLIB) $@
rm -rf tmp
@@ -47,7 +47,7 @@ endif # USE_LIBTOOL
include $(srcdir)/../../../Makefile.shared
-all: crt0.o
+all: crt0.o crt1.o
crt0.o: machine/crt0.o
rm -f $@