summaryrefslogtreecommitdiffstats
path: root/newlib/libc/sys/cygwin/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2004-09-14 18:12:53 +0000
committerJeff Johnston <jjohnstn@redhat.com>2004-09-14 18:12:53 +0000
commit98650d2fa2d2443ede83cc9f5d21d39e8078e60b (patch)
tree5497495f0c9328eb65766296b5589b08984afa37 /newlib/libc/sys/cygwin/Makefile.am
parent272871abe46d6c6e7329f20fb8665cc08910f9a9 (diff)
downloadcygnal-98650d2fa2d2443ede83cc9f5d21d39e8078e60b.tar.gz
cygnal-98650d2fa2d2443ede83cc9f5d21d39e8078e60b.tar.bz2
cygnal-98650d2fa2d2443ede83cc9f5d21d39e8078e60b.zip
2004-09-14 Jeff Johnston <jjohnstn@redhat.com>
* configure.host: Add Cygwin sys directory. * configure.in: Do not set CRT0 for cygwin. * libc/configure.in: Ditto. * libc/sys/configure.in: Ditto. * configure: Regenerated. * libc/configure: Ditto. * libc/sys/configure: Ditto. * libc/include/sys/reent.h: Add __REENT_HAS_CXA_SUPPORT flag. * libc/stdlib/__atexit.c: Keep cxa support protected by new __REENT_HAS_CXA_SUPPORT flag. * libc/stdlib/__call_atexit.c: Ditto. * libc/stdlib/cxa_atexit.c: Ditto. * libc/stdlib/cxa_finalize.c: Ditto. * libc/sys/cygwin/Makefile.am: New file. * libc/sys/cygwin/Makefile.in: Ditto. * libc/sys/cygwin/aclocal.m4: Ditto. * libc/sys/cygwin/configure: Ditto. * libc/sys/cygwin/configure.in: Ditto. * libc/sys/cygwin/dummy.c: Ditto. * libc/sys/cygwin/sys/reent.h: Ditto. This file is stabilized version of reent.h.
Diffstat (limited to 'newlib/libc/sys/cygwin/Makefile.am')
-rw-r--r--newlib/libc/sys/cygwin/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/newlib/libc/sys/cygwin/Makefile.am b/newlib/libc/sys/cygwin/Makefile.am
new file mode 100644
index 000000000..d41e23a66
--- /dev/null
+++ b/newlib/libc/sys/cygwin/Makefile.am
@@ -0,0 +1,12 @@
+## Process this file with automake to generate Makefile.in
+
+AUTOMAKE_OPTIONS = cygnus
+
+INCLUDES = $(NEWLIB_CFLAGS) $(CROSS_CFLAGS) $(TARGET_CFLAGS)
+
+noinst_LIBRARIES = lib.a
+
+lib_a_SOURCES = dummy.c
+
+ACLOCAL_AMFLAGS = -I ../../..
+CONFIG_STATUS_DEPENDENCIES = $(newlib_basedir)/configure.host