summaryrefslogtreecommitdiffstats
path: root/newlib/libc/string/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2002-05-24 23:44:39 +0000
committerJeff Johnston <jjohnstn@redhat.com>2002-05-24 23:44:39 +0000
commitd29587b4789426217ace96c1dccb249e3682eaf8 (patch)
tree5eb3816b224b613db0274c8bccd57ef729261b68 /newlib/libc/string/Makefile.am
parent8b3e5e2d6e5076769d90662db759ce5009c1ba9c (diff)
downloadcygnal-d29587b4789426217ace96c1dccb249e3682eaf8.tar.gz
cygnal-d29587b4789426217ace96c1dccb249e3682eaf8.tar.bz2
cygnal-d29587b4789426217ace96c1dccb249e3682eaf8.zip
2002-05-24 Jeff Johnston <jjohnstn@redhat.com>
* libc/include/string.h: Add strnlen and strerror_r prototypes. * libc/string/Makefile.am: Add strnlen.c and strerror_r.c support. * libc/string/Makefile.in: Regenerated. * libc/string/strerror_r.c: New file. * libc/string/strnlen.c: New file. * libc/sys/linux/Makefile.am: Add rename.c. * libc/sys/linux/Makefile.in: Regenerated. * libc/sys/linux/rename.c: New file to override default rename.
Diffstat (limited to 'newlib/libc/string/Makefile.am')
-rw-r--r--newlib/libc/string/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/newlib/libc/string/Makefile.am b/newlib/libc/string/Makefile.am
index a56522121..f90fed168 100644
--- a/newlib/libc/string/Makefile.am
+++ b/newlib/libc/string/Makefile.am
@@ -23,6 +23,7 @@ LIB_SOURCES = \
strcpy.c \
strcspn.c \
strerror.c \
+ strerror_r.c \
strlcat.c \
strlcpy.c \
strlen.c \
@@ -31,6 +32,7 @@ LIB_SOURCES = \
strncmp.c \
strncasecmp.c \
strncpy.c \
+ strnlen.c \
strpbrk.c \
strrchr.c \
strsep.c \
@@ -62,8 +64,8 @@ bcmp.def memcpy.def strcmp.def strncat.def strstr.def \
bcopy.def memmove.def strcoll.def strncmp.def strtok.def \
bzero.def memset.def strcpy.def strncpy.def strxfrm.def \
index.def rindex.def strcspn.def strpbrk.def swab.def \
-memchr.def strcat.def strerror.def strrchr.def \
-memcmp.def strchr.def strlen.def strspn.def \
+memchr.def strcat.def strerror.def strerror_r.def strrchr.def \
+memcmp.def strchr.def strlen.def strnlen.def strspn.def \
strcasecmp.def strncasecmp.def strlwr.def strupr.def
SUFFIXES = .def