summaryrefslogtreecommitdiffstats
path: root/newlib/libc/string/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2002-07-23 21:38:00 +0000
committerJeff Johnston <jjohnstn@redhat.com>2002-07-23 21:38:00 +0000
commitd254189b38bb5b0b77a18a401c05c415ce0733c9 (patch)
tree7a0a2dfa9e20a356bc0ba94eb20a26bef0c353d1 /newlib/libc/string/Makefile.am
parent5e50e4e45c1f8758d431a6d881cd3da5572e8de7 (diff)
downloadcygnal-d254189b38bb5b0b77a18a401c05c415ce0733c9.tar.gz
cygnal-d254189b38bb5b0b77a18a401c05c415ce0733c9.tar.bz2
cygnal-d254189b38bb5b0b77a18a401c05c415ce0733c9.zip
2002-07-23 Jeff Johnston <jjohnstn@redhat.com>
* libc/include/string.h: Add mempcpy, strndup, and _strndup_r prototypes. * libc/stdlib/Makefile.am: Remove strdup.c and strdup_r.c. * libc/stdlib/Makefile.in: Regenerated. * libc/stdlib/strdup.c: Removed. * libc/stdlib/strdup_r.c: Removed. * libc/string/Makefile.am: Add strdup.c, strdup_r.c, memccpy.c, mempcpy.c, strndup.c, and strndup_r.c. * libc/string/Makefile.in: Regenerated. * libc/string/memccpy.c: New file. * libc/string/mempcpy.c: Ditto. * libc/string/strndup.c: Ditto. * libc/string/strndup_r.c: Ditto. * libc/string/strdup.c: New file moved from stdlib. * libc/string/strdup_r.c: Ditto. * libc/string/strings.tex: Add memccpy and mempcpy documentation.
Diffstat (limited to 'newlib/libc/string/Makefile.am')
-rw-r--r--newlib/libc/string/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/newlib/libc/string/Makefile.am b/newlib/libc/string/Makefile.am
index f90fed168..525534e07 100644
--- a/newlib/libc/string/Makefile.am
+++ b/newlib/libc/string/Makefile.am
@@ -9,10 +9,12 @@ LIB_SOURCES = \
bcopy.c \
bzero.c \
index.c \
+ memccpy.c \
memchr.c \
memcmp.c \
memcpy.c \
memmove.c \
+ mempcpy.c \
memset.c \
rindex.c \
strcat.c \
@@ -22,6 +24,8 @@ LIB_SOURCES = \
strcoll.c \
strcpy.c \
strcspn.c \
+ strdup.c \
+ strdup_r.c \
strerror.c \
strerror_r.c \
strlcat.c \
@@ -32,6 +36,8 @@ LIB_SOURCES = \
strncmp.c \
strncasecmp.c \
strncpy.c \
+ strndup.c \
+ strndup_r.c \
strnlen.c \
strpbrk.c \
strrchr.c \
@@ -66,7 +72,8 @@ bzero.def memset.def strcpy.def strncpy.def strxfrm.def \
index.def rindex.def strcspn.def strpbrk.def swab.def \
memchr.def strcat.def strerror.def strerror_r.def strrchr.def \
memcmp.def strchr.def strlen.def strnlen.def strspn.def \
-strcasecmp.def strncasecmp.def strlwr.def strupr.def
+strcasecmp.def strncasecmp.def strlwr.def strupr.def memccpy.def \
+mempcpy.def
SUFFIXES = .def