summaryrefslogtreecommitdiffstats
path: root/newlib/libc/string/Makefile.am
diff options
context:
space:
mode:
authorCorinna Vinschen <corinna@vinschen.de>2007-07-04 16:18:34 +0000
committerCorinna Vinschen <corinna@vinschen.de>2007-07-04 16:18:34 +0000
commita37215120b3461103df702186805a3d4a88d5b77 (patch)
tree2d9d2c8b51f03b23f2e9c22aa10e0d54077c464e /newlib/libc/string/Makefile.am
parentc467d17e7c0aa05e3087c462954ee942a479c197 (diff)
downloadcygnal-a37215120b3461103df702186805a3d4a88d5b77.tar.gz
cygnal-a37215120b3461103df702186805a3d4a88d5b77.tar.bz2
cygnal-a37215120b3461103df702186805a3d4a88d5b77.zip
* libc/include/wchar.h: Add prototype for wcsxfrm.
* libc/string/Makefile.am (GENERAL_SOURCES): Add wcsxfrm.c. (CHEWOUT_FILES): Add wcsxfrm.def. * libc/string/Makefile.in: Regenerate. * libc/string/wcsxfrm.c: New file. * libc/string/wcstrings.tex: Add wcsxfrm.
Diffstat (limited to 'newlib/libc/string/Makefile.am')
-rw-r--r--newlib/libc/string/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/newlib/libc/string/Makefile.am b/newlib/libc/string/Makefile.am
index 94d1868fa..7c2778b13 100644
--- a/newlib/libc/string/Makefile.am
+++ b/newlib/libc/string/Makefile.am
@@ -63,6 +63,7 @@ GENERAL_SOURCES = \
wcsspn.c \
wcsstr.c \
wcswidth.c \
+ wcsxfrm.c \
wcwidth.c \
wmemchr.c \
wmemcmp.c \
@@ -113,7 +114,7 @@ wcscpy.def wcscspn.def \
wcslcat.def wcslcpy.def wcslen.def wcsncat.def \
wcsncmp.def wcsncpy.def wcsnlen.def wcspbrk.def \
wcsrchr.def wcsspn.def wcsstr.def \
-wcswidth.def wcwidth.def wmemchr.def \
+wcswidth.def wcsxfrm.def wcwidth.def wmemchr.def \
wmemcmp.def wmemcpy.def wmemmove.def wmemset.def
SUFFIXES = .def