summaryrefslogtreecommitdiffstats
path: root/newlib/libc/string/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2002-08-29 19:38:25 +0000
committerJeff Johnston <jjohnstn@redhat.com>2002-08-29 19:38:25 +0000
commit890e7a1d1a7d701e6e5e0674e58aebe595575375 (patch)
tree6da470c325a8768eb04188a5bfa6b34b39fe02e6 /newlib/libc/string/Makefile.am
parent86620e21902f8ad14acf919d15bb49b9455311a6 (diff)
downloadcygnal-890e7a1d1a7d701e6e5e0674e58aebe595575375.tar.gz
cygnal-890e7a1d1a7d701e6e5e0674e58aebe595575375.tar.bz2
cygnal-890e7a1d1a7d701e6e5e0674e58aebe595575375.zip
2002-08-29 Kazuhiro Fujieda <fujieda@jaist.ac.jp>
* libc/include/wchar.h: Define NULL. Define WEOF more general way. Declare functions in newlib manner. * libc/stdlib/Makefile.am: Delete wmem*.c * libc/stdlib/Makefile.in: Regenerated. * libc/stdlib/wmemchr.c: Delete. * libc/stdlib/wmemcmp.c: Ditto. * libc/stdlib/wmemcpy.c: Ditto. * libc/stdlib/wmemmove.c: Ditto. * libc/stdlib/wmemset.c: Ditto. * libc/string/Makefile.am: Add wmem*.c and wcs*.c. * libc/string/Makefile.in: Regenerated. * libc/string/wcscat.c: New file derived from the NetBSD C Library. * libc/string/wcschr.c: Ditto. * libc/string/wcscmp.c: Ditto. * libc/string/wcscpy.c: Ditto. * libc/string/wcscspn.c: Ditto. * libc/string/wcslcat.c: Ditto. * libc/string/wcslcpy.c: Ditto. * libc/string/wcslen.c: Ditto. * libc/string/wcsncat.c: Ditto. * libc/string/wcsncmp.c: Ditto. * libc/string/wcsncpy.c: Ditto. * libc/string/wcspbrk.c: Ditto. * libc/string/wcsrchr.c: Ditto. * libc/string/wcsspn.c: Ditto. * libc/string/wcsstr.c: Ditto. * libc/string/wmemchr.c: Ditto. * libc/string/wmemcmp.c: Ditto. * libc/string/wmemcpy.c: Ditto. * libc/string/wmemmove.c: Ditto. * libc/string/wmemset.c: Ditto.
Diffstat (limited to 'newlib/libc/string/Makefile.am')
-rw-r--r--newlib/libc/string/Makefile.am28
1 files changed, 26 insertions, 2 deletions
diff --git a/newlib/libc/string/Makefile.am b/newlib/libc/string/Makefile.am
index 1e4f4c525..9e9bdb481 100644
--- a/newlib/libc/string/Makefile.am
+++ b/newlib/libc/string/Makefile.am
@@ -44,7 +44,27 @@ GENERAL_SOURCES = \
strxfrm.c \
strstr.c \
swab.c \
- u_strerr.c
+ u_strerr.c \
+ wcscat.c \
+ wcschr.c \
+ wcscmp.c \
+ wcscpy.c \
+ wcscspn.c \
+ wcslcat.c \
+ wcslcpy.c \
+ wcslen.c \
+ wcsncat.c \
+ wcsncmp.c \
+ wcsncpy.c \
+ wcspbrk.c \
+ wcsrchr.c \
+ wcsspn.c \
+ wcsstr.c \
+ wmemchr.c \
+ wmemcmp.c \
+ wmemcpy.c \
+ wmemmove.c \
+ wmemset.c
if ELIX_LEVEL_1
LIB_OBJS =
@@ -83,7 +103,11 @@ index.def rindex.def strcspn.def strpbrk.def swab.def \
memchr.def strcat.def strerror.def strerror_r.def strrchr.def \
memcmp.def strchr.def strlen.def strnlen.def strspn.def \
strcasecmp.def strncasecmp.def strlwr.def strupr.def memccpy.def \
-mempcpy.def
+mempcpy.def \
+wcscat.def wcschr.def wcscmp.def wcscpy.def wcscspn.def \
+wcslcat.def wcslcpy.def wcslen.def wcsncat.def wcsncmp.def \
+wcsncpy.def wcspbrk.def wcsrchr.def wcsspn.def wcsstr.def \
+wmemchr.def wmemcmp.def wmemcpy.def wmemmove.def wmemset.def
SUFFIXES = .def