summaryrefslogtreecommitdiffstats
path: root/newlib/libc/string/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2016-03-18 11:49:25 +0100
committerCorinna Vinschen <corinna@vinschen.de>2016-03-18 12:33:40 +0100
commit8740fa7fd0f1eba18059b2794c9cdfe29ef564d3 (patch)
tree72cf4f30258df1d05830ecab109a3d8136b439af /newlib/libc/string/Makefile.am
parenta10dacbdac3ed9ad8e12e29473236cbbe0ff4e10 (diff)
downloadcygnal-8740fa7fd0f1eba18059b2794c9cdfe29ef564d3.tar.gz
cygnal-8740fa7fd0f1eba18059b2794c9cdfe29ef564d3.tar.bz2
cygnal-8740fa7fd0f1eba18059b2794c9cdfe29ef564d3.zip
Add explicit_bzero()
This function is used by LibreSSL and OpenSSH and is provided by the OpenBSD libc. * libc/include/string.h (explicit_bzero): Declare. * libc/string/explicit_bzero.c: New file. * libc/string/Makefile.am: Add new file. * libc/string/Makefile.in: Regenerate.
Diffstat (limited to 'newlib/libc/string/Makefile.am')
-rw-r--r--newlib/libc/string/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/newlib/libc/string/Makefile.am b/newlib/libc/string/Makefile.am
index e347ec43b..9b8e6b183 100644
--- a/newlib/libc/string/Makefile.am
+++ b/newlib/libc/string/Makefile.am
@@ -7,6 +7,7 @@ INCLUDES = $(NEWLIB_CFLAGS) $(CROSS_CFLAGS) $(TARGET_CFLAGS)
GENERAL_SOURCES = \
bcopy.c \
bzero.c \
+ explicit_bzero.c \
index.c \
memchr.c \
memcmp.c \