summaryrefslogtreecommitdiffstats
path: root/newlib/libc/string/Makefile.am
diff options
context:
space:
mode:
authorAlexandre Oliva <aoliva@redhat.com>2000-03-08 03:46:01 +0000
committerAlexandre Oliva <aoliva@redhat.com>2000-03-08 03:46:01 +0000
commit85dd2e5b73ef28bac042360f93733d9b4728c4ac (patch)
treedffcfb442d1efe39cac1e56f68e8836e727ee659 /newlib/libc/string/Makefile.am
parentc505305855a5c7c999c7adfa0271436b3ff6ee55 (diff)
downloadcygnal-85dd2e5b73ef28bac042360f93733d9b4728c4ac.tar.gz
cygnal-85dd2e5b73ef28bac042360f93733d9b4728c4ac.tar.bz2
cygnal-85dd2e5b73ef28bac042360f93733d9b4728c4ac.zip
* libc/string/Makefile.am (lib_a_SOURCES): Added swab.c.
(CHEWOUT_FILES): Added swab.def. * libc/string/Makefile.in: Rebuilt. * libc/string/string.tex: Include swab.def. * libc/include/string.h (swab): Declare. * libc/string/swab.c: New file.
Diffstat (limited to 'newlib/libc/string/Makefile.am')
-rw-r--r--newlib/libc/string/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/newlib/libc/string/Makefile.am b/newlib/libc/string/Makefile.am
index 26d4b8952..dceb4d909 100644
--- a/newlib/libc/string/Makefile.am
+++ b/newlib/libc/string/Makefile.am
@@ -39,13 +39,14 @@ lib_a_SOURCES = \
strupr.c \
strxfrm.c \
strstr.c \
+ swab.c \
u_strerr.c
CHEWOUT_FILES=\
bcmp.def memcpy.def strcmp.def strncat.def strstr.def \
bcopy.def memmove.def strcoll.def strncmp.def strtok.def \
bzero.def memset.def strcpy.def strncpy.def strxfrm.def \
-index.def rindex.def strcspn.def strpbrk.def \
+index.def rindex.def strcspn.def strpbrk.def swab.def \
memchr.def strcat.def strerror.def strrchr.def \
memcmp.def strchr.def strlen.def strspn.def \
strcasecmp.def strncasecmp.def strlwr.def strupr.def