summaryrefslogtreecommitdiffstats
path: root/newlib/libc/string/Makefile.am
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-02-10 16:48:18 +0000
committerEric Blake <eblake@redhat.com>2011-02-10 16:48:18 +0000
commit7c10a76dec8afaf548bf14453ebd689e3457518e (patch)
treec3e235b29e3a74fa8451f5d3f4c79977d0755296 /newlib/libc/string/Makefile.am
parent27aaf2a9d19de72291d77c45649951738b697f57 (diff)
downloadcygnal-7c10a76dec8afaf548bf14453ebd689e3457518e.tar.gz
cygnal-7c10a76dec8afaf548bf14453ebd689e3457518e.tar.bz2
cygnal-7c10a76dec8afaf548bf14453ebd689e3457518e.zip
strerror_r: provide POSIX implementation
* libc/include/string.h (strerror_r): Update declaration. * libc/string/strerror.c (strerror): Update documentation. * libc/string/strerror_r.c (strerror_r): Always return NUL-terminated string; don't overwrite too-short buf. * libc/string/xpg_strerror_r.c (__xpg_strerror_r): Implement POSIX variant. * libc/string/Makefile.am (GENERAL_SOURCES): Build new file. * libc/string/Makefile.in: Regenerate.
Diffstat (limited to 'newlib/libc/string/Makefile.am')
-rw-r--r--newlib/libc/string/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/newlib/libc/string/Makefile.am b/newlib/libc/string/Makefile.am
index 82fec8be1..561d0e5a0 100644
--- a/newlib/libc/string/Makefile.am
+++ b/newlib/libc/string/Makefile.am
@@ -71,7 +71,8 @@ GENERAL_SOURCES = \
wmemcmp.c \
wmemcpy.c \
wmemmove.c \
- wmemset.c
+ wmemset.c \
+ xpg_strerror_r.c
if ELIX_LEVEL_1
ELIX_2_SOURCES =