summaryrefslogtreecommitdiffstats
path: root/newlib/libc/string/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2007-06-08 18:38:51 +0000
committerJeff Johnston <jjohnstn@redhat.com>2007-06-08 18:38:51 +0000
commit6fb374754dff1fbbe28b513b57caedc62e9a7cee (patch)
tree1fb6bb0f26b02fcf53c2d5736343d49ffe7ddc50 /newlib/libc/string/Makefile.am
parent75715938641f75ab4e715fb7310683628097fd44 (diff)
downloadcygnal-6fb374754dff1fbbe28b513b57caedc62e9a7cee.tar.gz
cygnal-6fb374754dff1fbbe28b513b57caedc62e9a7cee.tar.bz2
cygnal-6fb374754dff1fbbe28b513b57caedc62e9a7cee.zip
2007-06-08 Jeff Johnston <jjohnstn@redhat.com>
* libc/string/strcasestr.c: New file. * libc/include/string.h: Add strcasestr. * libc/string/strings.tex: Add strcasestr. * libc/string/Makefile.am: Ditto. * libc/string/Makefile.in: Regenerated.
Diffstat (limited to 'newlib/libc/string/Makefile.am')
-rw-r--r--newlib/libc/string/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/newlib/libc/string/Makefile.am b/newlib/libc/string/Makefile.am
index dbe603628..e0482d82e 100644
--- a/newlib/libc/string/Makefile.am
+++ b/newlib/libc/string/Makefile.am
@@ -78,6 +78,7 @@ ELIX_SOURCES = \
memccpy.c \
mempcpy.c \
strndup.c \
+ strcasestr.c \
strndup_r.c
endif
@@ -103,8 +104,8 @@ bzero.def memset.def strcpy.def strncpy.def strxfrm.def \
index.def rindex.def strcspn.def strpbrk.def swab.def \
memchr.def strcat.def strerror.def strerror_r.def strrchr.def \
memcmp.def strchr.def strlen.def strnlen.def strspn.def \
-strcasecmp.def strncasecmp.def strlwr.def strupr.def memccpy.def \
-mempcpy.def \
+strcasecmp.def strncasecmp.def strcasestr.def strlwr.def strupr.def \
+memccpy.def mempcpy.def \
wcscat.def wcschr.def wcscmp.def wcscoll.def \
wcscpy.def wcscspn.def \
wcslcat.def wcslcpy.def wcslen.def wcsncat.def \