summaryrefslogtreecommitdiffstats
path: root/newlib/libc/string/Makefile.am
diff options
context:
space:
mode:
authorCorinna Vinschen <corinna@vinschen.de>2007-06-28 17:07:23 +0000
committerCorinna Vinschen <corinna@vinschen.de>2007-06-28 17:07:23 +0000
commit5d8b97a6942169497ba891acf86725ec87afa60b (patch)
treeb802738264b2f57d3088579c0d9ffae9a7a09633 /newlib/libc/string/Makefile.am
parenta4b5a24055334025e399b3d1b06985a39beeaa84 (diff)
downloadcygnal-5d8b97a6942169497ba891acf86725ec87afa60b.tar.gz
cygnal-5d8b97a6942169497ba891acf86725ec87afa60b.tar.bz2
cygnal-5d8b97a6942169497ba891acf86725ec87afa60b.zip
* libc/include/string.h: Add prototypes for stpcpy and stpncpy.
* libc/string/Makefile.am (ELIX_SOURCES): Add stpcpy.c and stpncpy.c. (CHEWOUT_FILES): Add stpcpy.def and stpncpy.def. * libc/string/Makefile.in: Regenerate. * libc/string/stpcpy.c: New file. * libc/string/stpncpy.c: New file. * libc/string/strings.tex: Add stpcpy and stpncpy.
Diffstat (limited to 'newlib/libc/string/Makefile.am')
-rw-r--r--newlib/libc/string/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/newlib/libc/string/Makefile.am b/newlib/libc/string/Makefile.am
index e0482d82e..94d1868fa 100644
--- a/newlib/libc/string/Makefile.am
+++ b/newlib/libc/string/Makefile.am
@@ -77,6 +77,8 @@ ELIX_SOURCES = \
bcmp.c \
memccpy.c \
mempcpy.c \
+ stpcpy.c \
+ stpncpy.c \
strndup.c \
strcasestr.c \
strndup_r.c
@@ -105,7 +107,7 @@ index.def rindex.def strcspn.def strpbrk.def swab.def \
memchr.def strcat.def strerror.def strerror_r.def strrchr.def \
memcmp.def strchr.def strlen.def strnlen.def strspn.def \
strcasecmp.def strncasecmp.def strcasestr.def strlwr.def strupr.def \
-memccpy.def mempcpy.def \
+memccpy.def mempcpy.def stpcpy.def stpncpy.def \
wcscat.def wcschr.def wcscmp.def wcscoll.def \
wcscpy.def wcscspn.def \
wcslcat.def wcslcpy.def wcslen.def wcsncat.def \