summaryrefslogtreecommitdiffstats
path: root/newlib/libc/string/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2016-03-18 11:49:26 +0100
committerCorinna Vinschen <corinna@vinschen.de>2016-03-18 12:33:40 +0100
commit559fd77ddac907da598202c23f103fc940f15ff8 (patch)
tree502f0f2236526840efda91ce2038da5d381966af /newlib/libc/string/Makefile.am
parent8740fa7fd0f1eba18059b2794c9cdfe29ef564d3 (diff)
downloadcygnal-559fd77ddac907da598202c23f103fc940f15ff8.tar.gz
cygnal-559fd77ddac907da598202c23f103fc940f15ff8.tar.bz2
cygnal-559fd77ddac907da598202c23f103fc940f15ff8.zip
Add timingsafe_bcmp()
This function is used by LibreSSL and OpenSSH and is provided by the OpenBSD libc. * libc/include/string.h (timingsafe_bcmp): Declare. * libc/string/timingsafe_bcmp.c: New file. * libc/string/Makefile.am: Add new file. * libc/string/Makefile.in: Regenerate.
Diffstat (limited to 'newlib/libc/string/Makefile.am')
-rw-r--r--newlib/libc/string/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/newlib/libc/string/Makefile.am b/newlib/libc/string/Makefile.am
index 9b8e6b183..c227bbda9 100644
--- a/newlib/libc/string/Makefile.am
+++ b/newlib/libc/string/Makefile.am
@@ -46,6 +46,7 @@ GENERAL_SOURCES = \
strxfrm.c \
strstr.c \
swab.c \
+ timingsafe_bcmp.c \
u_strerr.c \
wcscat.c \
wcschr.c \