summaryrefslogtreecommitdiffstats
path: root/newlib/libc/stdlib/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2015-10-14 07:39:37 +0200
committerCorinna Vinschen <corinna@vinschen.de>2015-10-19 14:10:33 +0200
commitf86afe5a3ac62a92e821c764a011e1625abdd326 (patch)
treedb2e6fdf1a2c1dff0aff989d197b066b427cd1ee /newlib/libc/stdlib/Makefile.am
parentda60762bfeda8c48cd06dbde45b224b31a82ae57 (diff)
downloadcygnal-f86afe5a3ac62a92e821c764a011e1625abdd326.tar.gz
cygnal-f86afe5a3ac62a92e821c764a011e1625abdd326.tar.bz2
cygnal-f86afe5a3ac62a92e821c764a011e1625abdd326.zip
C11 aligned_alloc() implementation
aligned_alloc() is implemented in terms of posix_memalign() which is only declared in <stdlib.h> but not defined in Newlib in general. At least Linux and RTEMS implement this function. newlib/ChangeLog 2015-10-14 Sebastian Huber <sebastian.huber@embedded-brains.de> * libc/stdlib/Makefile.am (GENERAL_SOURCES): Add alloc_aligned.c.c. * libc/stdlib/Makefile.in: Regenerate. * libc/stdlib/aligned_alloc.c: New.
Diffstat (limited to 'newlib/libc/stdlib/Makefile.am')
-rw-r--r--newlib/libc/stdlib/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/newlib/libc/stdlib/Makefile.am b/newlib/libc/stdlib/Makefile.am
index 5c0e14290..ead5dd190 100644
--- a/newlib/libc/stdlib/Makefile.am
+++ b/newlib/libc/stdlib/Makefile.am
@@ -13,6 +13,7 @@ GENERAL_SOURCES = \
_Exit.c \
abort.c \
abs.c \
+ aligned_alloc.c \
assert.c \
atexit.c \
atof.c \