summaryrefslogtreecommitdiffstats
path: root/newlib/libc/stdlib/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2006-05-01 22:01:07 +0000
committerJeff Johnston <jjohnstn@redhat.com>2006-05-01 22:01:07 +0000
commit8f8f1db12f5ac069d7e44c7ea9b2eed55f2b0b96 (patch)
tree63736be05c366aa4eb54d745238770f758ea659b /newlib/libc/stdlib/Makefile.am
parent0015de8d38a42066853e29ce2ff543578ad28299 (diff)
downloadcygnal-8f8f1db12f5ac069d7e44c7ea9b2eed55f2b0b96.tar.gz
cygnal-8f8f1db12f5ac069d7e44c7ea9b2eed55f2b0b96.tar.bz2
cygnal-8f8f1db12f5ac069d7e44c7ea9b2eed55f2b0b96.zip
2006-05-01 Jeff Johnston <jjohnstn@redhat.com>
* libc/argz/Makefile.am: Prefix any objects specified with $(lpfx). If source file can be specified instead of object, do so. * libc/ctype/Makefile.am: Ditto. * libc/iconv/ccs/Makefile.am: Ditto. * libc/iconv/ces/Makefile.am: Ditto. * libc/iconv/lib/Makefile.am: Ditto. * libc/locale/Makefile.am: Ditto. * libc/posix/Makefile.am: Ditto. * libc/reent/Makefile.am: Ditto. * libc/search/Makefile.am: Ditto. * libc/stdio/Makefile.am: Ditto. * libc/stdio64/Makefile.am: Ditto. * libc/stdlib/Makefile.am: Ditto. * libc/string/Makefile.am: Ditto. * libc/syscalls/Makefile.am: Ditto. * libc/unix/Makefile.am: Ditto. * libc/machine/a29k/Makefile.am: Specify lib_a_CCASFLAGS so .S files will get prefix added automatically. Any specified rules must use $(lpfx) for object file names. * libc/machine/arm/Makefile.am: Ditto. * libc/machine/cris/Makefile.am: Ditto. * libc/machine/crx/Makefile.am: Ditto. * libc/machine/d10v/Makefile.am: Ditto. * libc/machine/d30v/Makefile.am: Ditto. * libc/machine/fr30/Makefile.am: Ditto. * libc/machine/frv/Makefile.am: Ditto. * libc/machine/h8300/Makefile.am: Ditto. * libc/machine/h8500/Makefile.am: Ditto. * libc/machine/hppa/Makefile.am: Ditto. * libc/machine/i386/Makefile.am: Ditto. * libc/machine/i960/Makefile.am: Ditto. * libc/machine/iq2000/Makefile.am: Ditto. * libc/machine/m32c/Makefile.am: Ditto. * libc/machine/m32r/Makefile.am: Ditto. * libc/machine/m68hc11/Makefile.am: Ditto. * libc/machine/m68k/Makefile.am: Ditto. * libc/machine/m88k/Makefile.am: Ditto. * libc/machine/mips/Makefile.am: Ditto. * libc/machine/mn10200/Makefile.am: Ditto. * libc/machine/mn10300/Makefile.am: Ditto. * libc/machine/mt/Makefile.am: Ditto. * libc/machine/necv70/Makefile.am: Ditto. * libc/machine/powerpc/Makefile.am: Ditto. * libc/machine/sh/Makefile.am: Ditto. * libc/machine/sh/Makefile.in: Ditto. * libc/machine/sparc/Makefile.am: Ditto. * libc/machine/tic4x/Makefile.am: Ditto. * libc/machine/tic80/Makefile.am: Ditto. * libc/machine/v850/Makefile.am: Ditto. * libc/machine/w65/Makefile.am: Ditto. * libc/machine/xscale/Makefile.am: Ditto. * libc/machine/xstormy16/Makefile.am: Ditto. * libc/machine/z8k/Makefile.am: Ditto. * libc/sys/a29khif/Makefile.am: Ditto. * libc/sys/arm/Makefile.am: Ditto. * libc/sys/d10v/Makefile.am: Ditto. * libc/sys/h8300hms/Makefile.am: Ditto. * libc/sys/h8500hms/Makefile.am: Ditto. * libc/sys/linux/Makefile.am: Ditto. * libc/sys/linux/linuxthreads/Makefile.am: Ditto. * libc/sys/linux/net/Makefile.am: Ditto. * libc/sys/linux/stdlib/Makefile.am: Ditto. * libc/sys/m88kbug/Makefile.am: Ditto. * libc/sys/mmixware/Makefile.am: Ditto. * libc/sys/rdos/Makefile.am: Ditto. * libc/sys/rtems/Makefile.am: Ditto. * libc/sys/sh/Makefile.am: Ditto. * libc/sys/sun4/Makefile.am: Ditto. * libc/sys/sysmec/Makefile.am: Ditto. * libc/sys/sysnec810/Makefile.am: Ditto. * libc/sys/sysnecv850/Makefile.am: Ditto. * libc/sys/sysvi386/Makefile.am: Ditto. * libc/sys/sysvnecv70/Makefile.am: Ditto. * libc/sys/tic80/Makefile.am: Ditto. * libc/sys/w65/Makefile.am: Ditto. * libc/sys/z8ksim/Makefile.am: Ditto. * libc/machine/necv70/fastmath.S: Renamed from .s file. * libc/machine/necv70/setjmp.S: Ditto. * libc/machine/necv70/fastmath.s: Removed. * libc/machine/necv70/setjmp.s: Ditto. * libc/machine/w65/*.S: New files renamed from .s files. * libc/machine/w65/*.s: Renamed and removed. * libc/sys/a29khif/*.S: New files renamed from .s files. * libc/sys/a29khif/*.s: Renamed and removed. * libc/sys/sysvi386/*.S: New files renamed from .s files. * libc/sys/sysvi386/*.s: Renamed and removed. * libc/sys/sysvnecv70/*.S: New files renamed from .s files. * libc/sys/sysvnecv70/*.s: Renamed and removed. * libc/*Makefile.in: Regenerated as appropriate.
Diffstat (limited to 'newlib/libc/stdlib/Makefile.am')
-rw-r--r--newlib/libc/stdlib/Makefile.am146
1 files changed, 77 insertions, 69 deletions
diff --git a/newlib/libc/stdlib/Makefile.am b/newlib/libc/stdlib/Makefile.am
index ef3e18777..fdc52e04e 100644
--- a/newlib/libc/stdlib/Makefile.am
+++ b/newlib/libc/stdlib/Makefile.am
@@ -78,69 +78,77 @@ EXTENDED_SOURCES = \
llabs.c \
lldiv.c
+ELIX_2_SOURCES = \
+ a64l.c \
+ btowc.c \
+ getopt.c \
+ getsubopt.c \
+ l64a.c \
+ malign.c \
+ mbrlen.c \
+ mbrtowc.c \
+ mbsinit.c \
+ mbsrtowcs.c \
+ on_exit.c \
+ valloc.c \
+ wcrtomb.c \
+ wcsrtombs.c \
+ wctob.c
+
ELIX_2_OBJS = \
- a64l.$(oext) \
- btowc.$(oext) \
- getopt.$(oext) \
- getsubopt.$(oext) \
- l64a.$(oext) \
- malign.$(oext) \
- malignr.$(oext) \
- malloptr.$(oext) \
- mbrlen.$(oext) \
- mbrtowc.$(oext) \
- mbsinit.$(oext) \
- mbsrtowcs.$(oext) \
- on_exit.$(oext) \
- pvallocr.$(oext) \
- valloc.$(oext) \
- vallocr.$(oext) \
- wcrtomb.$(oext) \
- wcsrtombs.$(oext) \
- wctob.$(oext)
-
-ELIX_3_OBJS = \
- putenv.$(oext) \
- putenv_r.$(oext) \
- setenv.$(oext) \
- setenv_r.$(oext)
-
-ELIX_4_OBJS = \
- system.$(oext)
+ $(lpfx)malignr.$(oext) \
+ $(lpfx)malloptr.$(oext) \
+ $(lpfx)pvallocr.$(oext) \
+ $(lpfx)vallocr.$(oext)
+
+ELIX_3_SOURCES = \
+ putenv.c \
+ putenv_r.c \
+ setenv.c \
+ setenv_r.c
+
+ELIX_4_SOURCES = \
+ system.c
if ELIX_LEVEL_1
-LIB_OBJS =
+ELIX_SOURCES =
+ELIX_OBJS =
else
if ELIX_LEVEL_2
-LIB_OBJS = $(ELIX_2_OBJS)
+ELIX_SOURCES = $(ELIX_2_SOURCES)
+ELIX_OBJS = $(ELIX_2_OBJS)
else
if ELIX_LEVEL_3
-LIB_OBJS = $(ELIX_2_OBJS) $(ELIX_3_OBJS)
+ELIX_SOURCES = $(ELIX_2_SOURCES) $(ELIX_3_SOURCES)
+ELIX_OBJS = $(ELIX_2_OBJS)
else
-LIB_OBJS = $(ELIX_2_OBJS) $(ELIX_3_OBJS) $(ELIX_4_OBJS)
+ELIX_SOURCES = $(ELIX_2_SOURCES) $(ELIX_3_SOURCES) $(ELIX_4_SOURCES)
+ELIX_OBJS = $(ELIX_2_OBJS)
endif
endif
endif
# Because of how libtool moves objects around, mallocr must be built last.
-LIBADD_OBJS = freer.$(oext) reallocr.$(oext) callocr.$(oext) cfreer.$(oext) \
- mallinfor.$(oext) mallstatsr.$(oext) msizer.$(oext) mallocr.$(oext)
+LIBADD_OBJS = $(lpfx)freer.$(oext) $(lpfx)reallocr.$(oext) \
+ $(lpfx)callocr.$(oext) $(lpfx)cfreer.$(oext) \
+ $(lpfx)mallinfor.$(oext) $(lpfx)mallstatsr.$(oext) \
+ $(lpfx)msizer.$(oext) $(lpfx)mallocr.$(oext)
libstdlib_la_LDFLAGS = -Xcompiler -nostdlib
if USE_LIBTOOL
noinst_LTLIBRARIES = libstdlib.la
-libstdlib_la_SOURCES = $(GENERAL_SOURCES) $(EXTENDED_SOURCES)
-libstdlib_la_LIBADD = $(LIB_OBJS) $(LIBADD_OBJS)
-libstdlib_la_DEPENDENCIES = $(LIB_OBJS) $(LIBADD_OBJS)
+libstdlib_la_SOURCES = $(GENERAL_SOURCES) $(EXTENDED_SOURCES) $(ELIX_SOURCES)
+libstdlib_la_LIBADD = $(LIBADD_OBJS) $(ELIX_OBJS)
+libstdlib_la_DEPENDENCIES = $(LIBADD_OBJS) $(ELIX_OBJS)
LIB_COMPILE = $(LTCOMPILE)
noinst_DATA = objectlist.awk.in
else
noinst_LIBRARIES = lib.a
-lib_a_SOURCES = $(GENERAL_SOURCES) $(EXTENDED_SOURCES)
-lib_a_LIBADD = $(LIBADD_OBJS) $(LIB_OBJS)
+lib_a_SOURCES = $(GENERAL_SOURCES) $(EXTENDED_SOURCES) $(ELIX_SOURCES)
+lib_a_LIBADD = $(LIBADD_OBJS) $(ELIX_OBJS)
lib_a_CFLAGS = $(AM_CFLAGS)
-lib_a_DEPENDENCIES = $(LIBADD_OBJS) $(LIB_OBJS)
+lib_a_DEPENDENCIES = $(LIBADD_OBJS) $(ELIX_OBJS)
LIB_COMPILE = $(COMPILE)
noinst_DATA =
endif # USE_LIBTOOL
@@ -149,40 +157,40 @@ include $(srcdir)/../../Makefile.shared
MALLOC_COMPILE = $(LIB_COMPILE) -DINTERNAL_NEWLIB
-mallocr.$(oext): mallocr.c
+$(lpfx)mallocr.$(oext): mallocr.c
$(MALLOC_COMPILE) -DDEFINE_MALLOC -c $(srcdir)/mallocr.c -o $@
-freer.$(oext): mallocr.c
+$(lpfx)freer.$(oext): mallocr.c
$(MALLOC_COMPILE) -DDEFINE_FREE -c $(srcdir)/mallocr.c -o $@
-reallocr.$(oext): mallocr.c
+$(lpfx)reallocr.$(oext): mallocr.c
$(MALLOC_COMPILE) -DDEFINE_REALLOC -c $(srcdir)/mallocr.c -o $@
-callocr.$(oext): mallocr.c
+$(lpfx)callocr.$(oext): mallocr.c
$(MALLOC_COMPILE) -DDEFINE_CALLOC -c $(srcdir)/mallocr.c -o $@
-cfreer.$(oext): mallocr.c
+$(lpfx)cfreer.$(oext): mallocr.c
$(MALLOC_COMPILE) -DDEFINE_CFREE -c $(srcdir)/mallocr.c -o $@
-malignr.$(oext): mallocr.c
+$(lpfx)malignr.$(oext): mallocr.c
$(MALLOC_COMPILE) -DDEFINE_MEMALIGN -c $(srcdir)/mallocr.c -o $@
-vallocr.$(oext): mallocr.c
+$(lpfx)vallocr.$(oext): mallocr.c
$(MALLOC_COMPILE) -DDEFINE_VALLOC -c $(srcdir)/mallocr.c -o $@
-pvallocr.$(oext): mallocr.c
+$(lpfx)pvallocr.$(oext): mallocr.c
$(MALLOC_COMPILE) -DDEFINE_PVALLOC -c $(srcdir)/mallocr.c -o $@
-mallinfor.$(oext): mallocr.c
+$(lpfx)mallinfor.$(oext): mallocr.c
$(MALLOC_COMPILE) -DDEFINE_MALLINFO -c $(srcdir)/mallocr.c -o $@
-mallstatsr.$(oext): mallocr.c
+$(lpfx)mallstatsr.$(oext): mallocr.c
$(MALLOC_COMPILE) -DDEFINE_MALLOC_STATS -c $(srcdir)/mallocr.c -o $@
-msizer.$(oext): mallocr.c
+$(lpfx)msizer.$(oext): mallocr.c
$(MALLOC_COMPILE) -DDEFINE_MALLOC_USABLE_SIZE -c $(srcdir)/mallocr.c -o $@
-malloptr.$(oext): mallocr.c
+$(lpfx)malloptr.$(oext): mallocr.c
$(MALLOC_COMPILE) -DDEFINE_MALLOPT -c $(srcdir)/mallocr.c -o $@
CHEWOUT_FILES= \
@@ -240,22 +248,22 @@ doc: $(CHEWOUT_FILES)
CLEANFILES = $(CHEWOUT_FILES) *.ref
-dtoa.$(oext): dtoa.c mprec.h
-ldtoa.$(oext): ldtoa.c mprec.h
-ecvtbuf.$(oext): ecvtbuf.c mprec.h
-mbtowc_r.$(oext): mbtowc_r.c mbctype.h
+$(lpfx)dtoa.$(oext): dtoa.c mprec.h
+$(lpfx)ldtoa.$(oext): ldtoa.c mprec.h
+$(lpfx)ecvtbuf.$(oext): ecvtbuf.c mprec.h
+$(lpfx)mbtowc_r.$(oext): mbtowc_r.c mbctype.h
$(LIB_COMPILE) -c -fshort-enums $(srcdir)/mbtowc_r.c -o $@
-mprec.$(oext): mprec.c mprec.h
-strtod.$(oext): strtod.c mprec.h
-wctomb_r.$(oext): wctomb_r.c mbctype.h
-drand48.$(oext): drand48.c rand48.h
-erand48.$(oext): erand48.c rand48.h
-jrand48.$(oext): jrand48.c rand48.h
-lcong48.$(oext): lcong48.c rand48.h
-lrand48.$(oext): lrand48.c rand48.h
-mrand48.$(oext): mrand48.c rand48.h
-nrand48.$(oext): nrand48.c rand48.h
-rand48.$(oext): rand48.c rand48.h
-seed48.$(oext): seed48.c rand48.h
-srand48.$(oext): srand48.c rand48.h
+$(lpfx)mprec.$(oext): mprec.c mprec.h
+$(lpfx)strtod.$(oext): strtod.c mprec.h
+$(lpfx)wctomb_r.$(oext): wctomb_r.c mbctype.h
+$(lpfx)drand48.$(oext): drand48.c rand48.h
+$(lpfx)erand48.$(oext): erand48.c rand48.h
+$(lpfx)jrand48.$(oext): jrand48.c rand48.h
+$(lpfx)lcong48.$(oext): lcong48.c rand48.h
+$(lpfx)lrand48.$(oext): lrand48.c rand48.h
+$(lpfx)mrand48.$(oext): mrand48.c rand48.h
+$(lpfx)nrand48.$(oext): nrand48.c rand48.h
+$(lpfx)rand48.$(oext): rand48.c rand48.h
+$(lpfx)seed48.$(oext): seed48.c rand48.h
+$(lpfx)srand48.$(oext): srand48.c rand48.h