summaryrefslogtreecommitdiffstats
path: root/newlib/libc/stdlib/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2008-11-19 20:56:22 +0000
committerJeff Johnston <jjohnstn@redhat.com>2008-11-19 20:56:22 +0000
commit8ee939ea9f395f95357612d64d9be8e9a6529e46 (patch)
tree69f67c24be31e64b3973adbbacef499e6f753299 /newlib/libc/stdlib/Makefile.am
parente231c7dae90002f4aa9a6e8bdb445a0bd6c392ae (diff)
downloadcygnal-8ee939ea9f395f95357612d64d9be8e9a6529e46.tar.gz
cygnal-8ee939ea9f395f95357612d64d9be8e9a6529e46.tar.bz2
cygnal-8ee939ea9f395f95357612d64d9be8e9a6529e46.zip
2008-11-19 Jeff Johnston <jjohnstn@redhat.com>
* libc/sys/linux/bits/dirent.h: New header file. * libc/sys/linux/sys/dirent.h: Include <bits/dirent.h> instead of <linux/dirent.h>. * libc/posix/Makefile.am: Remove reallocf. * libc/posix/Makefile.in: Regenerated. * libc/posix/reallocf.c: Moved to... * libc/stdlib/reallocf.c: Here * libc/stdlib/malloc.c: Add reallocf documentation. * libc/include/stdlib.h: Add reallocf and _reallocf_r prototypes. * libc/stdlib/Makefile.am: Add reallocf. * libc/stdlib/Makefile.in: Regenerated. * libc/posix/_isatty.c: Set errno.
Diffstat (limited to 'newlib/libc/stdlib/Makefile.am')
-rw-r--r--newlib/libc/stdlib/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/newlib/libc/stdlib/Makefile.am b/newlib/libc/stdlib/Makefile.am
index ce3bcbca4..e63ea0334 100644
--- a/newlib/libc/stdlib/Makefile.am
+++ b/newlib/libc/stdlib/Makefile.am
@@ -47,6 +47,7 @@ GENERAL_SOURCES = \
rand.c \
rand_r.c \
realloc.c \
+ reallocf.c \
strtod.c \
strtol.c \
strtoul.c \