summaryrefslogtreecommitdiffstats
path: root/newlib/libc/stdlib/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2000-12-06 23:50:11 +0000
committerJeff Johnston <jjohnstn@redhat.com>2000-12-06 23:50:11 +0000
commit6bdac416e9e1aecfb94cd3ae383889cc7b7e62e3 (patch)
tree0871ae257bee23aa786ad2ac43aeb3470d340f5f /newlib/libc/stdlib/Makefile.am
parent81e615de9818b0094abea875b60ca955edfcec9c (diff)
downloadcygnal-6bdac416e9e1aecfb94cd3ae383889cc7b7e62e3.tar.gz
cygnal-6bdac416e9e1aecfb94cd3ae383889cc7b7e62e3.tar.bz2
cygnal-6bdac416e9e1aecfb94cd3ae383889cc7b7e62e3.zip
2000-12-06 Jeff Johnston <jjohnstn@redhat.com>
* libc/stdlib/Makefile.am: Added ldtoa.c to list of sources. * libc/stdlib/Makefile.in: Regenerated. * libc/stdio/floatio.h: Added suitable MAXEXP for long double. * libc/stdio/vfieeefp.h: Added long double bit structures. * libc/stdio/vfprintf.c[WANT_IO_LONG_DBL]: Added long double support. [WANT_IO_LONG_DBL](isinfl, isnanl): New static long double routines. (exponent): Changed expbuf to reasonable maximum instead of MAXEXP. * libc/stdio/vfscanf.c[WANT_IO_LONG_DBL]: Added long double support. * libc/stdlib/ldtoa.c: New file containing _ldtoa_r and _strtold routines used for conversions between character and long double.
Diffstat (limited to 'newlib/libc/stdlib/Makefile.am')
-rw-r--r--newlib/libc/stdlib/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/newlib/libc/stdlib/Makefile.am b/newlib/libc/stdlib/Makefile.am
index f33550fc7..e6d60dbc3 100644
--- a/newlib/libc/stdlib/Makefile.am
+++ b/newlib/libc/stdlib/Makefile.am
@@ -34,6 +34,7 @@ lib_a_SOURCES = \
getopt.c \
labs.c \
ldiv.c \
+ ldtoa.c \
malign.c \
malloc.c \
mblen.c \
@@ -157,6 +158,7 @@ doc: $(CHEWOUT_FILES)
CLEANFILES = $(CHEWOUT_FILES) *.ref
dtoa.o: dtoa.c mprec.h
+ldtoa.o: ldtoa.c mprec.h
ecvtbuf.o: ecvtbuf.c mprec.h
mbtowc_r.o: mbtowc_r.c mbctype.h
$(COMPILE) -c -fshort-enums $(srcdir)/mbtowc_r.c -o $@