summaryrefslogtreecommitdiffstats
path: root/newlib/libc/stdlib/Makefile.am
diff options
context:
space:
mode:
authorCorinna Vinschen <corinna@vinschen.de>2014-12-16 10:55:17 +0000
committerCorinna Vinschen <corinna@vinschen.de>2014-12-16 10:55:17 +0000
commit32c96ddd14acadc82e7fccf110367ec3c8320c85 (patch)
treefdaf1181e21438f85ab0991cd246d6fa513cfc32 /newlib/libc/stdlib/Makefile.am
parent21f22726c77917d98d9cbe01f05843fdd7189df9 (diff)
downloadcygnal-32c96ddd14acadc82e7fccf110367ec3c8320c85.tar.gz
cygnal-32c96ddd14acadc82e7fccf110367ec3c8320c85.tar.bz2
cygnal-32c96ddd14acadc82e7fccf110367ec3c8320c85.zip
* libc/include/stdlib.h (__itoa): Declare prototype.
(__utoa): Ditto. (itoa): Ditto, non-strict-ANSI only. (utoa): Ditto. * libc/stdlib/Makefile.am: Add itoa.c and utoa.c. * libc/stdlib/Makefile.in: Regenerate. * libc/stdlib/itoa.c: New file. * libc/stdlib/utoa.c: New file.
Diffstat (limited to 'newlib/libc/stdlib/Makefile.am')
-rw-r--r--newlib/libc/stdlib/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/newlib/libc/stdlib/Makefile.am b/newlib/libc/stdlib/Makefile.am
index 22fedcc84..e90517f85 100644
--- a/newlib/libc/stdlib/Makefile.am
+++ b/newlib/libc/stdlib/Makefile.am
@@ -31,6 +31,7 @@ GENERAL_SOURCES = \
gdtoa-hexnan.c \
getenv.c \
getenv_r.c \
+ itoa.c \
labs.c \
ldiv.c \
ldtoa.c \
@@ -52,6 +53,7 @@ GENERAL_SOURCES = \
strtod.c \
strtol.c \
strtoul.c \
+ utoa.c \
wcstod.c \
wcstol.c \
wcstoul.c \
@@ -257,6 +259,7 @@ CHEWOUT_FILES= \
envlock.def \
exit.def \
getenv.def \
+ itoa.def \
labs.def \
ldiv.def \
llabs.def \
@@ -277,6 +280,7 @@ CHEWOUT_FILES= \
strtoll.def \
strtoul.def \
strtoull.def \
+ utoa.def \
wcsnrtombs.def \
wcstod.def \
wcstol.def \