summaryrefslogtreecommitdiffstats
path: root/newlib/libc/stdio/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2002-06-21 18:29:23 +0000
committerJeff Johnston <jjohnstn@redhat.com>2002-06-21 18:29:23 +0000
commitd427d09204c97df14607149e94a1da9beddd76ab (patch)
tree364e68aebab51cfb339ff2b0f21a1f97d22a131d /newlib/libc/stdio/Makefile.am
parent35728d4f142bbab0d8a963561d76b9066421b1ac (diff)
downloadcygnal-d427d09204c97df14607149e94a1da9beddd76ab.tar.gz
cygnal-d427d09204c97df14607149e94a1da9beddd76ab.tar.bz2
cygnal-d427d09204c97df14607149e94a1da9beddd76ab.zip
2002-06-21 Jeff Johnston <jjohnstn@redhat.com>
* libc/include/stdio.h (__getline, __getdelim): New prototypes. * libc/include/time.h [HAVE_GETDATE](getdate, getdate_r): Ditto. [HAVE_GETDATE](getdate_err): New error code. * libc/stdio/Makefile.am: Add support for getline.c and getdelim.c. * libc/stdio/Makefile.in: Regenerated. * libc/stdio/getdelim.c: New file. * libc/stdio/getline.c: Ditto. * libc/sys/linux/Makefile.am: Add support for getdate.c, getdate_err.c and ntp_gettime.c. Also add AM_CFLAGS to point to libc/stdio. * libc/sys/linux/Makefile.in: Regenerated. * libc/sys/linux/getdate.c: New file. * libc/sys/linux/getdate_err.c: Ditto. * libc/sys/linux/ntp_gettime.c: Ditto. * libc/sys/linux/time.c (adjtimex, ntp_adjtime): New functions. * libc/sys/linux/sys/stdio.h (getline, getdelim): New macros.
Diffstat (limited to 'newlib/libc/stdio/Makefile.am')
-rw-r--r--newlib/libc/stdio/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/newlib/libc/stdio/Makefile.am b/newlib/libc/stdio/Makefile.am
index e7d4fea21..b7eaab8e4 100644
--- a/newlib/libc/stdio/Makefile.am
+++ b/newlib/libc/stdio/Makefile.am
@@ -35,6 +35,8 @@ LIB_SOURCES = \
getchar.c \
getc_u.c \
getchar_u.c \
+ getdelim.c \
+ getline.c \
gets.c \
getw.c \
iprintf.c \
@@ -129,6 +131,8 @@ CHEWOUT_FILES = \
getchar.def \
getc_u.def \
getchar_u.def \
+ getdelim.def \
+ getline.def \
gets.def \
getw.def \
iprintf.def \