summaryrefslogtreecommitdiffstats
path: root/newlib/libc/stdio/Makefile.am
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2007-08-02 20:23:06 +0000
committerEric Blake <eblake@redhat.com>2007-08-02 20:23:06 +0000
commit6ddcdb9da510ddf2b6309006ded0827f467e23b4 (patch)
treef0e349d3cc7ad6083b3a652e688d385215a41dc8 /newlib/libc/stdio/Makefile.am
parent191814588af712faa0093d21a08c51c97abae3f2 (diff)
downloadcygnal-6ddcdb9da510ddf2b6309006ded0827f467e23b4.tar.gz
cygnal-6ddcdb9da510ddf2b6309006ded0827f467e23b4.tar.bz2
cygnal-6ddcdb9da510ddf2b6309006ded0827f467e23b4.zip
Implement fmemopen and open_memstream.
* libc/stdio/fmemopen.c (_fmemopen_r, fmemopen): New file. * libc/stdio/open_memstream.c (_open_memstream_r, open_memstream): New file. * libc/stdio/fopencookie.c (fcwriter): Minor optimization. * libc/include/stdio.h (dprintf, vdprintf): Group all POSIX 200x functions together. (fmemopen, open_memstream): Declare new functions. * libc/stdio/stdio.tex: Document them. * libc/stdio/Makefile.am (ELIX_4_SOURCES, CHEWOUT_FILES): Add fmemopen and open_memstream. * libc/stdio/Makefile.in: Regenerate.
Diffstat (limited to 'newlib/libc/stdio/Makefile.am')
-rw-r--r--newlib/libc/stdio/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/newlib/libc/stdio/Makefile.am b/newlib/libc/stdio/Makefile.am
index 2b7cb62d9..4d3daaefb 100644
--- a/newlib/libc/stdio/Makefile.am
+++ b/newlib/libc/stdio/Makefile.am
@@ -117,8 +117,10 @@ ELIX_4_SOURCES = \
asnprintf.c \
diprintf.c \
dprintf.c \
+ fmemopen.c \
fopencookie.c \
funopen.c \
+ open_memstream.c \
vasniprintf.c \
vasnprintf.c
endif !ELIX_LEVEL_3
@@ -179,6 +181,7 @@ CHEWOUT_FILES = \
fgetpos.def \
fgets.def \
fileno.def \
+ fmemopen.def \
fopen.def \
fopencookie.def \
fputc.def \
@@ -199,6 +202,7 @@ CHEWOUT_FILES = \
gets.def \
getw.def \
mktemp.def \
+ open_memstream.def \
perror.def \
putc.def \
putc_u.def \
@@ -244,6 +248,7 @@ $(lpfx)fclose.$(oext): local.h
$(lpfx)fdopen.$(oext): local.h
$(lpfx)fflush.$(oext): local.h
$(lpfx)findfp.$(oext): local.h
+$(lpfx)fmemopen.$(oext): local.h
$(lpfx)fopen.$(oext): local.h
$(lpfx)fopencookie.$(oext): local.h
$(lpfx)fputs.$(oext): fvwrite.h
@@ -257,6 +262,7 @@ $(lpfx)fwalk.$(oext): local.h
$(lpfx)fwrite.$(oext): local.h fvwrite.h
$(lpfx)iscanf.$(oext): local.h
$(lpfx)makebuf.$(oext): local.h
+$(lpfx)open_memstream.$(oext): local.h
$(lpfx)puts.$(oext): fvwrite.h
$(lpfx)refill.$(oext): local.h
$(lpfx)scanf.$(oext): local.h