summaryrefslogtreecommitdiffstats
path: root/newlib/libc/posix/Makefile.am
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2008-01-03 22:33:37 +0000
committerJeff Johnston <jjohnstn@redhat.com>2008-01-03 22:33:37 +0000
commita639937a9ab176d7c38c1de7ef0d3b0d7643f856 (patch)
treefd9ae999b3c58f387d75c0f12136cf720013ceba /newlib/libc/posix/Makefile.am
parent7c8bd7a075a84a4d9010334b0f0cfc6cf45f49a7 (diff)
downloadcygnal-a639937a9ab176d7c38c1de7ef0d3b0d7643f856.tar.gz
cygnal-a639937a9ab176d7c38c1de7ef0d3b0d7643f856.tar.bz2
cygnal-a639937a9ab176d7c38c1de7ef0d3b0d7643f856.zip
2008-01-03 Jeff Johnston <jjohnstn@redhat.com>
Make isatty syscall handling consistent with other newlib syscalls. * libc/include/_syslist.h: Add _isatty. * libc/include/reent.h: Add _isatty_r. * libc/include/sys/unistd.h: Add _isatty. * libc/posix/Makefile.am: Add new _isatty.c file. * libc/posix/Makefile.in: Regenerated. * libc/posix/_isatty.c: New file. * libc/posix/isatty.c: Changed to call _isatty(). * libc/reent/Makefile.am: Add new isattyr.c file. * libc/reent/Makefile.in: Regenerated. * libc/reent/isattyr.c: New file. * libc/stdio/freopen.c: Changed to call _isatty_r(). * libc/stdio/makebuf.c: Ditto. * libc/sys/a29khif/_isatty.S: Change isatty to _isatty. * libc/sys/arc/isatty.c: Ditto. * libc/sys/arm/syscalls.c: Ditto. * libc/sys/d10v/syscalls.c: Ditto. * libc/sys/h8300hms/syscalls.c: Ditto. * libc/sys/h8500hms/syscalls.c: Ditto. * libc/sys/linux/Makefile.am: Add new isatty.c file. * libc/sys/linux/Makefile.in: Regenerated. * libc/sys/linux/isatty.c: New file. * libc/syscalls/Makefile.am: Add new sysisatty.c file. * libc/syscalls/Makefile.in: Regenerated. * libc/syscalls/sysisatty.c: New file.
Diffstat (limited to 'newlib/libc/posix/Makefile.am')
-rw-r--r--newlib/libc/posix/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/newlib/libc/posix/Makefile.am b/newlib/libc/posix/Makefile.am
index 649451645..2091b4110 100644
--- a/newlib/libc/posix/Makefile.am
+++ b/newlib/libc/posix/Makefile.am
@@ -5,7 +5,7 @@ AUTOMAKE_OPTIONS = cygnus
INCLUDES = $(NEWLIB_CFLAGS) $(CROSS_CFLAGS) $(TARGET_CFLAGS)
GENERAL_SOURCES = \
- closedir.c creat.c isatty.c \
+ closedir.c creat.c _isatty.c isatty.c \
opendir.c readdir.c \
readdir_r.c rewinddir.c sleep.c usleep.c \
telldir.c