summaryrefslogtreecommitdiffstats
path: root/libgloss/mep/configure.in
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2007-02-08 21:22:05 +0000
committerJeff Johnston <jjohnstn@redhat.com>2007-02-08 21:22:05 +0000
commit1d94f7311465ca3c972541fc2c7c02255640d29c (patch)
tree645846719ee345cc3ff3bcd28b40b6baf69e43ea /libgloss/mep/configure.in
parentaafecff6a8081056a732b78582f7eebb5f6fd022 (diff)
downloadcygnal-1d94f7311465ca3c972541fc2c7c02255640d29c.tar.gz
cygnal-1d94f7311465ca3c972541fc2c7c02255640d29c.tar.bz2
cygnal-1d94f7311465ca3c972541fc2c7c02255640d29c.zip
2007-02-08 Dave Brolley <brolley@redhat.com>
* mep: New target directory. * README: Add MeP. * configure.in: Add support for MeP. * configure: Regenerated. * mep/configure.in: New file. * mep/configure: Ditto. * mep/Makefile.in: Ditto. * mep/aclocal.m4: Ditto. * mep/crt0.S: Ditto. * mep/crtn.S: Ditto. * mep/sim-crt0.S: Ditto. * mep/sim-crtn.S: Ditto. * mep/fmax.ld: Ditto. * mep/gcov-io.h: Ditto. * mep/gmap_default.ld: Ditto. * mep/handlers.c: Ditto. * mep/h_reset.c: Ditto. * mep/isatty.c: Ditto. * mep/mep-bb.c: Ditto. * mep/mep-gmon.c: Ditto. * mep/min.ld: Ditto. * mep/read.c: Ditto. * mep/sbrk.c: Ditto. * mep/sdram-crt0.S: Ditto. * mep/sdram-crtn.S: Ditto. * mep/simnovec-crt0.S: Ditto. * mep/simple.ld: Ditto. * mep/simsdran-crt0.S: Ditto. * mep/syscalls.S: Ditto. * mep/write.c: Ditto.
Diffstat (limited to 'libgloss/mep/configure.in')
-rw-r--r--libgloss/mep/configure.in66
1 files changed, 66 insertions, 0 deletions
diff --git a/libgloss/mep/configure.in b/libgloss/mep/configure.in
new file mode 100644
index 000000000..328b5d856
--- /dev/null
+++ b/libgloss/mep/configure.in
@@ -0,0 +1,66 @@
+dnl Copyright (c) 2000-2007 Red Hat, Inc. All rights reserved.
+dnl
+dnl This copyrighted material is made available to anyone wishing to use,
+dnl modify, copy, or redistribute it subject to the terms and conditions of
+dnl the BSD License. This program is distributed in the hope that
+dnl it will be useful, but WITHOUT ANY WARRANTY expressed or implied,
+dnl including the implied warranties of MERCHANTABILITY or FITNESS FOR A
+dnl PARTICULAR PURPOSE. A copy of this license is available at
+dnl http://www.opensource.org/licenses. Any Red Hat trademarks that are
+dnl incorporated in the source code or documentation are not subject to the
+dnl BSD License and may only be used or replicated with the express permission
+dnl of Red Hat, Inc.
+
+dnl Process this file with autoconf to produce a configure script.
+AC_PREREQ(2.59)
+AC_INIT(crt0.S)
+
+if test "${enable_shared}" = "yes" ; then
+ echo "Shared libraries not supported for cross compiling, ignored"
+fi
+
+if test "$srcdir" = "." ; then
+ if test "${with_target_subdir}" != "." ; then
+ libgloss_topdir="${srcdir}/${with_multisrctop}../../.."
+ else
+ libgloss_topdir="${srcdir}/${with_multisrctop}../.."
+ fi
+else
+ libgloss_topdir="${srcdir}/../.."
+fi
+AC_CONFIG_AUX_DIR($libgloss_topdir)
+
+AC_CANONICAL_SYSTEM
+AC_ARG_PROGRAM
+
+AC_PROG_INSTALL
+
+LIB_AC_PROG_CC
+AS=${AS-as}
+AC_SUBST(AS)
+AR=${AR-ar}
+AC_SUBST(AR)
+LD=${LD-ld}
+AC_SUBST(LD)
+AC_PROG_RANLIB
+
+host_makefile_frag=${srcdir}/../config/default.mh
+
+dnl We have to assign the same value to other variables because autoconf
+dnl doesn't provide a mechanism to substitute a replacement keyword with
+dnl arbitrary data or pathnames.
+dnl
+host_makefile_frag_path=$host_makefile_frag
+AC_SUBST(host_makefile_frag_path)
+AC_SUBST_FILE(host_makefile_frag)
+
+AC_CONFIG_FILES([Makefile],
+. ${libgloss_topdir}/config-ml.in,
+srcdir=${srcdir}
+target=${target}
+with_multisubdir=${with_multisubdir}
+ac_configure_args="${ac_configure_args} --enable-multilib"
+CONFIG_SHELL=${CONFIG_SHELL-/bin/sh}
+libgloss_topdir=${libgloss_topdir}
+)
+AC_OUTPUT