summaryrefslogtreecommitdiffstats
path: root/libgloss/m68k/configure.in
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2002-04-16 19:10:48 +0000
committerJeff Johnston <jjohnstn@redhat.com>2002-04-16 19:10:48 +0000
commitdad32754b99f5950c815fa86ad8c149c7a0ca2d0 (patch)
treef3b1dbb8e45f97e2266333781d02b83bac9c9b92 /libgloss/m68k/configure.in
parent284dfa2a428c71af586ff96bdebf8c7532b82149 (diff)
downloadcygnal-dad32754b99f5950c815fa86ad8c149c7a0ca2d0.tar.gz
cygnal-dad32754b99f5950c815fa86ad8c149c7a0ca2d0.tar.bz2
cygnal-dad32754b99f5950c815fa86ad8c149c7a0ca2d0.zip
2002-04-16 Jeff Johnston <jjohnstn@redhat.com>
* m68k/configure.in: Change to use LIB_AC_PROG_CC instead of AC_PROG_CC to avoid building an executable in configuration. * m68k/configure: Regenerated.
Diffstat (limited to 'libgloss/m68k/configure.in')
-rw-r--r--libgloss/m68k/configure.in41
1 files changed, 40 insertions, 1 deletions
diff --git a/libgloss/m68k/configure.in b/libgloss/m68k/configure.in
index 177022633..6cb89ca16 100644
--- a/libgloss/m68k/configure.in
+++ b/libgloss/m68k/configure.in
@@ -34,7 +34,46 @@ AC_ARG_PROGRAM
AC_PROG_INSTALL
-AC_PROG_CC
+# FIXME: We temporarily define our own version of AC_PROG_CC. This is
+# copied from autoconf 2.12, but does not call AC_PROG_CC_WORKS. We
+# are probably using a cross compiler, which will not be able to fully
+# link an executable. This should really be fixed in autoconf
+# itself.
+
+AC_DEFUN(LIB_AC_PROG_CC,
+[AC_BEFORE([$0], [AC_PROG_CPP])dnl
+AC_CHECK_PROG(CC, gcc, gcc)
+if test -z "$CC"; then
+ AC_CHECK_PROG(CC, cc, cc, , , /usr/ucb/cc)
+ test -z "$CC" && AC_MSG_ERROR([no acceptable cc found in \$PATH])
+fi
+
+AC_PROG_CC_GNU
+
+if test $ac_cv_prog_gcc = yes; then
+ GCC=yes
+dnl Check whether -g works, even if CFLAGS is set, in case the package
+dnl plays around with CFLAGS (such as to build both debugging and
+dnl normal versions of a library), tasteless as that idea is.
+ ac_test_CFLAGS="${CFLAGS+set}"
+ ac_save_CFLAGS="$CFLAGS"
+ CFLAGS=
+ AC_PROG_CC_G
+ if test "$ac_test_CFLAGS" = set; then
+ CFLAGS="$ac_save_CFLAGS"
+ elif test $ac_cv_prog_cc_g = yes; then
+ CFLAGS="-g -O2"
+ else
+ CFLAGS="-O2"
+ fi
+else
+ GCC=
+ test "${CFLAGS+set}" = set || CFLAGS="-g"
+fi
+])
+
+LIB_AC_PROG_CC
+
AS=${AS-as}
AC_SUBST(AS)
AR=${AR-ar}